Skocz do zawartości

Zdjęcie

xampp (apache) Port 80 in use by "Unable to open process" with PID 4!

problem z xampp apache port in use port w użyciu

Najlepsza odpowiedź zonic, 02 grudzień 2013 - 14:05

Dokładnie. Skype, ewentualnie jakiś iis czy SQL Server.

Najpewniej polecam zajrzeć do pliku konfiguracyjnego apache: httpd.conf znaleźć tam linijkę:

 

Listen 80 

i zamienić port na przykład na 12345

Potem restart apache i odwołujemy się w przeglądarce poprzez: localhost:12345/ do głównego folderu htdocs

Przejdź do postu


6 odpowiedzi w tym temacie
  • Zamknięty Temat jest zamknięty
studenciak

    Użytkownik

  • 53 postów
    • Czas spędzony online: 3h 6m 29s
4
Neutralna

Napisano 02 grudzień 2013 - 13:01

#1
12:52:25  [Apache] 	Problem detected!
12:52:25  [Apache] 	Port 80 in use by "Unable to open process" with PID 4!
12:52:25  [Apache] 	Apache WILL NOT start without the configured ports free!
12:52:25  [Apache] 	You need to uninstall/disable/reconfigure the blocking application
12:52:25  [Apache] 	or reconfigure Apache and the Control Panel to listen on a different port
12:52:26  [main] 	Starting Check-Timer
12:52:26  [main] 	Control Panel Ready
12:52:29  [Apache] 	Problem detected!
12:52:29  [Apache] 	Port 80 in use by "Unable to open process" with PID 4!
12:52:29  [Apache] 	Apache WILL NOT start without the configured ports free!
12:52:29  [Apache] 	You need to uninstall/disable/reconfigure the blocking application
12:52:29  [Apache] 	or reconfigure Apache and the Control Panel to listen on a different port

Mam problem z XAMPPem i Apache. Komunikat widoczny powyżej. Rozumiem, że mam zajęty port 80, ale netstat pokazuje, że proces, który go używa to System. Jak sprawdzić dokładnie, co go używa? 


  • 0

unbreak

    WT Elite

  • 1937 postów
    • Czas spędzony online: 27d 8h 41m 42s
506
Znakomita!
  • Location/home/unbreak

Napisano 02 grudzień 2013 - 13:45

#2

Najczęściej to włączony Skype, masz go? To go wyłącz na czas uruchamiania Apache.


  • 1

webDeveloper


zonic

    WT Elite

  • 2911 postów
    • Czas spędzony online: 134d 2h 28m 23s
472
Znakomita!
  • LocationToruń

Napisano 02 grudzień 2013 - 14:05   Najlepsza odpowiedź

#3

Dokładnie. Skype, ewentualnie jakiś iis czy SQL Server.

Najpewniej polecam zajrzeć do pliku konfiguracyjnego apache: httpd.conf znaleźć tam linijkę:

 

Listen 80 

i zamienić port na przykład na 12345

Potem restart apache i odwołujemy się w przeglądarce poprzez: localhost:12345/ do głównego folderu htdocs


  • 1

unbreak

    WT Elite

  • 1937 postów
    • Czas spędzony online: 27d 8h 41m 42s
506
Znakomita!
  • Location/home/unbreak

Napisano 02 grudzień 2013 - 15:12

#4

Albo zamiast korzystać z localhost:12345 to w httpd.conf lub httpd-vhosts.conf (zależy jak tam masz ustawione) ustawić odpowiednio vhosta:

NameVirtualHost *:12345

Swoją drogą polecam: http://forum.podkrec...w-na-localhost/


  • 2

webDeveloper


vms

    Użytkownik

  • 81 postów
    • Czas spędzony online: 5h 33m 5s
28
Bardzo dobra

Napisano 06 grudzień 2013 - 23:54

#5

A nie lepiej zmienić ustawienia skype? Zamiast majstrować w apache'u?


  • 1

zonic

    WT Elite

  • 2911 postów
    • Czas spędzony online: 134d 2h 28m 23s
472
Znakomita!
  • LocationToruń

Napisano 07 grudzień 2013 - 07:30

#6

A nie lepiej zmienić ustawienia skype? Zamiast majstrować w apache'u?

Jakie to ma znaczenie, co zmienimy? :)


  • 0

unbreak

    WT Elite

  • 1937 postów
    • Czas spędzony online: 27d 8h 41m 42s
506
Znakomita!
  • Location/home/unbreak

Napisano 09 grudzień 2013 - 09:29

#7

A nie lepiej zmienić ustawienia skype? Zamiast majstrować w apache'u?

Zgadza się, wystarczy odznaczyć w ustawieniach Zaawansowanych (połączenia) "Użyj portów 80 oraz..."


  • -1

webDeveloper





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych